Microsoft Excel Tutorial Reference Guide

This document is intended to be a supplemental aid to the Excel Tutorial videos and be a quick reference to come back to. There are titles in this document indicating which topics are discussed in each video. Click on the quick links below to go the desired topic. It is highly recommended that this document is not the sole tutorial that is used, as the videos will provide a more comprehensive visual aid.

DIRECTORY

<table>
<thead>
<tr>
<th>Opening a New Excel Workbook</th>
<th>3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Closing the Workbook</td>
<td>3</td>
</tr>
<tr>
<td>Saving the Workbook</td>
<td>3</td>
</tr>
<tr>
<td>Installing the Analysis ToolPak</td>
<td>3</td>
</tr>
<tr>
<td>Entering Data into Cells</td>
<td>3</td>
</tr>
<tr>
<td>Renaming a Worksheet</td>
<td>3</td>
</tr>
<tr>
<td>Superscripts &amp; Subscripts in Cells</td>
<td>3</td>
</tr>
<tr>
<td>Changing Column Width</td>
<td>4</td>
</tr>
<tr>
<td>Merging Cells</td>
<td>4</td>
</tr>
<tr>
<td>Wrapping Text</td>
<td>4</td>
</tr>
<tr>
<td>Defining Cell Type</td>
<td>4</td>
</tr>
<tr>
<td>Changing Decimal Numbers</td>
<td>4</td>
</tr>
<tr>
<td>Auto Filling Cells</td>
<td>5</td>
</tr>
<tr>
<td>Sorting Data</td>
<td>5</td>
</tr>
<tr>
<td>Transposing Data</td>
<td>5</td>
</tr>
<tr>
<td>Making Custom Formulae</td>
<td>5</td>
</tr>
<tr>
<td>Editing a Formula</td>
<td>5</td>
</tr>
<tr>
<td>Entering a Built-in Function</td>
<td>6</td>
</tr>
<tr>
<td>Clicking and Dragging Formulae</td>
<td>6</td>
</tr>
<tr>
<td>Copying and Pasting Formulae</td>
<td>6</td>
</tr>
<tr>
<td>Absolute Referencing</td>
<td>6</td>
</tr>
<tr>
<td>Inserting a Scatter Plot</td>
<td>6</td>
</tr>
<tr>
<td>Adding a Data Series to a Blank Plot</td>
<td>7</td>
</tr>
<tr>
<td>Adding Axis Titles</td>
<td>8</td>
</tr>
<tr>
<td>Moving a Legend</td>
<td>8</td>
</tr>
<tr>
<td>Changing Tick Marks</td>
<td>9</td>
</tr>
<tr>
<td>Modifying Axis Ranges</td>
<td>9</td>
</tr>
</tbody>
</table>
Formatting Gridlines ............................................................................................................... 10
Formatting Border Styles ..................................................................................................... 10
Adding Error Bars .................................................................................................................. 11
Changing Error Bar Values .................................................................................................. 11
Changing Data Series Markers ............................................................................................ 12
Copying a Table or Graph Into Word .................................................................................. 13
Adding a Trendline to Series ............................................................................................... 13
Changing Variable in Chart Equations .............................................................................. 14
Opening Analysis ToolPak ................................................................................................... 14
Performing a Regression Analysis ....................................................................................... 14
Understanding Regression Outputs ..................................................................................... 15
  Underneath the table labelled Regression Statistics ....................................................... 15
  From the 3rd table with column headings including Coefficients, Standard Error, etc. ........ 15
  Residuals ............................................................................................................................. 15
Using Descriptive Statistics ................................................................................................. 16
Example Table ....................................................................................................................... 16
Video 1

Opening a New Excel Workbook:
Double click the Excel Icon and click New Blank Workbook

Closing the Workbook:
Click the “X” in the upper right-hand corner of the window

Saving the Workbook:
Select the File tab at the top left to go Backstage. Select Save As and navigate to the correct directory using Browse to locate your folder. Give it a descriptive file name and save it as an Excel workbook, meaning it will have the “.xlsx” extension.

Installing the Analysis ToolPak:
Click the File tab to bring up the Backstage, and then select Options in order to bring up the Excel Options menu. Navigate to the Add-Ins tab on the left menu. At the bottom of the Add-Ins tab, click the Go button beside the drop-down menu, ensuring that you are managing Excel Add-ins. A pop-up window will appear with several unchecked boxes. Check the box that corresponds to Analysis ToolPak and then click OK.

Video 2.1

Entering Data into Cells:
Left click the cell under the correct column and type in numbers only. In Excel, cells with numbers are automatically right aligned and cells with any lettered elements are left aligned. This can be changed using the Alignment options in the Home tab.

Renaming a Worksheet:
At the bottom of the page, double click on the title Sheet 1 (or right-click and select Rename). Type in the desired name, then press Enter.

Superscripts & Subscripts in Cells:
Highlight the text to be changed. In the Home tab under the Font group, bring up the Font menu by clicking the arrow in the bottom right corner of the group as seen in Figure 1. In the Font tab on the resulting menu, tick the Subscript or Superscript box depending on which is necessary. The press OK or the Enter key.

Figure 1: Font group in the Home tab
Changing Column Width:
Move the cursor to the line separating the column letters at the top of the Excel window. This should change the cursor to a vertical line with arrows pointing in opposite directions. Click and drag the cursor to the right to adjust the column width manually or double-click to auto adjust the column width to the longest entry.

Merging Cells:
Select all the cells to be merged, then click the Merge and Center button in the Alignment group of the Home tab as seen in Figure 2.

![Alignment group in the Home tab with Merge & Center highlighted](image)

Figure 2: Alignment group in the Home tab with Merge & Center highlighted

Wrapping Text:
Select the cell or column to be formatted with wrapped text then in the Alignment Tab in the Home menu select Wrap Text as seen in Figure 3.

![Alignment group in the Home tab with Wrap Text highlighted](image)

Figure 3: Alignment group in the Home tab with Wrap Text highlighted

Defining Cell Type:
After selecting the cell or column, use the drop-down menu in the Number group in the Home tab as seen in Figure 4. Options include General, Number, Scientific and Percentage among others. Choose the most appropriate type to format the data (in most cases, General is sufficient).

![Number group in the Home tab](image)

Figure 4: Number group in the Home tab

Changing Decimal Numbers:
Select the cells to be formatted, then use the One Less Decimal or One More Decimal buttons located in the Number group of the Home tab as seen in Figure 5.
Auto Filling Cells:
Type in the first few entries into the column. Once sufficient cells have been filled (usually around 3), select all of the column entries currently filled by clicking the middle of the topmost cells and dragging until all the column entries are highlighted and surrounded by a green border. At the bottom right of the green border will appear a small green square once the click is released as seen in Figure 6. Click the square and drag down to populate as many cells as necessary. All cells populated with this method will follow the pattern Excel deems.

Sorting Data:
Select all data columns and navigate to Sort in the Sort and Filter group of the Data tab. Column headers may be included, as long as the My data has headers box is ticked when performing the sort. Click the Sort button to bring up the Sort window. Next, use the drop-down menus to specify the criterion by which the data is to be sorted, an in which order it should be rearranged. The Options button can be used to sort case sensitive or to have a special sort order such as days of the week or months of the year. Once the criteria are set up, click OK.

Transposing Data:
Copy the data by selecting all desired columns then pressing Ctrl. C. Right click on the first cell in which the data is to be transposed to. In the resultant Quick Menu, select Transpose under the Paste Options.

Video 2.2
Making Custom Formulae:
Select the cell and start with an equal sign =. Use parentheses, operations (+, -, *, /, ^) and click on the cells to be referenced in the formula. Evaluate the answer by pressing <Enter>

Editing a Formula:
There are multiple ways to edit a formula: double clicking the cell, selecting the cell and pressing F2 or clicking the formula bar just above the column headers.
**Entering a Built-in Function:**
Type ‘=’ then input the code for the desired function. <Enter> will evaluate the cell. Some helpful functions have been included in Table 1 below.

<table>
<thead>
<tr>
<th>Name</th>
<th>Syntax</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sum</td>
<td>SUM(element1, element2, ...)</td>
<td>Sums all the elements in parentheses</td>
</tr>
<tr>
<td>Average</td>
<td>AVERAGE(element1, element2, ...)</td>
<td>Finds the average of all input elements</td>
</tr>
<tr>
<td>Sine</td>
<td>SIN(angle)</td>
<td>Finds the sine of a given angle</td>
</tr>
<tr>
<td>Natural Logarithm</td>
<td>LN(value)</td>
<td>Takes the ln of a given value</td>
</tr>
<tr>
<td>Exponential</td>
<td>EXP(value)</td>
<td>Takes e to the exponent of the value</td>
</tr>
<tr>
<td>Count</td>
<td>COUNT(element1, element2, ...)</td>
<td>Counts the number of input elements</td>
</tr>
<tr>
<td>Absolute Value</td>
<td>ABS(value)</td>
<td>Takes the absolute value of an input value</td>
</tr>
</tbody>
</table>

**Clicking and Dragging Formulae:**
Select the cell containing the original formula, then click the bottom right-hand corner of the cell where the green square is as seen in Figure 7. Click and drag the cursor down to the last row in which the formula is needed, or double click to populate automatically to the lowest row with data. When this is done, it will move any reference cells down to the corresponding reference cells in the new row. To prevent this, use absolute referencing.

![Figure 7: A highlighted formula cell with a circle around the square in the corner and an arrow indicating to select and drag](image)

**Copying and Pasting Formulae:**
Select the cell to be copied and press <Ctrl> and C, then paste it in the cells intended for evaluation using <Ctrl> and V.

**Absolute Referencing:**
When referencing the cell to be made an absolute and add $ symbols before and after the column letter, such as $B$2 or $AA$34

**Video 3**

**Inserting a Scatter Plot:**
In the Insert tab under the Charts group, as seen in Figure 8, select Scatter Plot.
Figure 8: Charts group in the Insert tab

Adding a Data Series to a Blank Plot:

Right-click on the blank plot and click Select Data in the Quick Menu as seen in Figure 9. In the Select Data Source window, as seen in Figure 10, click Add. Write a descriptive name in the Series Name dialogue box in the Edit Series window as seen in Figure 11. In the Series X values dialogue box, click the Collapse arrow beside the box. This will allow for the data to be input by clicking and dragging the desired data. Hit <Enter> to return to the Edit Series window. Input the y data in the same way using the Series Y values dialogue box. Once all data has been input, click OK on the Edit Series and Select Data Source windows.

Figure 9: Dat, Type, and Location groups in the Chart Design tab

Figure 10: Select Data Source window
Figure 11: Edit Series window

Adding Axis Titles:

After clicking on the plot, either click the Green Plus in the top right corner of the plot as seen in Figure 12 or the Chart Tools tab. If in the Green Plus, check the Axis Titles box, then unclick the Chart Title box. If in the Chart Tools tab, click Add Chart Elements in the Chart Layouts Group and select both Primary Horizontal and Primary Vertical under the Axis Titles tab and select None under the Chart Titles tab. Edit the axis titles by clicking on the plot, then double clicking the axis title (three clicks in total).

This technique can also be used to add a Legend.

Figure 12: A chart with the Green Plus circled

Moving a Legend:

Once a legend has been added using the checkbox in the Green Plus menu, it will default to not overlapping the plot. This minimizes the plot area and is an ineffective placement. In order to allow the legend to overlap, right-click on the legend and select Format Legend. In the resulting toolbar, uncheck the Show the Legend Without Overlapping The Chart box as seen in Figure 13. The chart is now free moving and can be moved by Clicking & Dragging the legend.
Changing Tick Marks:
Right-click on the axis line, then select Format Axis, which will cause a toolbar to appear on the right of the window. Under the Axis Options tab in the Format Axis window, click the Tick Marks drop down menu and change the Major type to Inside as seen in Figure 14. Repeat this procedure for the other axis by either repeating the steps or using the Chart Elements drop down menu in the toolbar to change to the other axis.

Modifying Axis Ranges:
Right-click on the axis line, then select Format Axis. Under the Axis Options tab in the Format Axis window, click the Axis Options drop down menu. The first option in the menu is the Bounds option as seen in Figure 15, with a text box for both minimum and maximum. These boxes are automatically set when the plot has data added to it and will remain that way unless explicitly changed. The range should be set to show a decent spread of the data, with the left-bottommost range of the data being set to zero when applicable. To reset to the automatically generated ranges, click the Reset button next to each range. The type of data the axis presents can be changed in the Number section, where both the Type of data and Decimal Places. Repeat this procedure with the other axis.
Formatting Gridlines:

Right-click on either set of gridlines (inside the graph axes) then select **Format Gridlines**. Under the **Line** tab, select **No Line**. Then either right click on the other set of gridlines to repeat this process or click the top dropdown menu in the toolbar and select the other axis **Major Gridlines Options** as seen in Figure 16.

Formatting Border Styles:

After removing the gridlines, Right-click the white area of the plot and select **Format Plot Area**. Under the **Border** tab, select **Solid Line**, then change the colour to **black** as seen in Figure 17. In order to make a consistent black border around the entire plot, use the drop-down menu in the Toolbar to go to **Format Axis** and change the axis to a **Solid Line** with **black colour**.
Adding Error Bars:
Click on the plot to cause the Green plus to appear in the top right corner. Click on the green plus and check the error bars box. This will add both horizontal and vertical error bars to all series, automatically generated by Excel.

Changing Error Bar Values:
There are five (5) different ways in Excel to input the desired values of error bars as seen in Figure 18. The Direction option allows for the error bars to go in both the positive and negative directions, or in only one of them. Except for the Custom option, any value will apply directly to the specified directions of the error bars. Fixed will set every error bar to the value specified in the textbox. Use this textbox to remove error bars by inputting 0. This is useful if horizontal error bars are not necessary for the plot due to the fact that Excel will automatically add both styles. Percentage will make the error bars a specified percentage of the value of each data point, changing throughout the series in absolute value. Standard Deviation will create error bars around the Mean of the data, not centered around the data points, that are the length of x standard deviations. Standard Error will cause the error bars to reflect the standard error of a regression analysis. Custom allows values to be set to each data point individually. By clicking the arrow to the right of the input box as seen in Figure 19, a cell range can be highlighted. This does not have to be the same range for positive and negative bars, which allows the error to be specified for each point.
Changing Data Series Markers:
In order to see some error bars, the markers may have to be adjusted. Click on the data series, then right-click on any of the points and select Format Data Series. Click the Fill & Line button (the paint bucket), then click on the Marker button. Under Marker Options, click Built-In, then change the size as seen in Figure 20. From this window, the shape of the data markers can also be changed.
Figure 20: Format Data Series toolbar

Copying a Table or Graph Into Word:
While it does work to click <Ctrl> and V to paste a table or graph from Excel into Word, it will not update if the Excel file undergoes changes. To fix this, Right-Click where the graph or table is to be copied and select either option that Links Data.

Video 4

Adding a Trendline to Series:
Right-click on any of the data points in a series, then select Add Trendline. This will bring up the trendline toolbar as seen in Figure 21, where the style of trendline can be changed under Trendline Options. For APSC 100, Linear is the most common type. To show the equation and correlation coefficient, check the boxes for Display Equation on Chart and Display R-Squared Value on Chart. The name of the trendline can be adjusted by typing in the Custom textbook under the Trendline Name Heading.
Changing Variable in Chart Equations:
The equations produced on the graph are in the default $y = mx + b$ form. To change the variables, double click on the textbox containing the given equation. The last value of the textbox may have to be deleted before anything else can be changed in the box. After the last character has been deleted and typed back in, the variables in the rest of the equation can then be changed to the appropriate variables. **Once the textbox has been altered, the numbers will not update with a change in the data or trendline, and the textbox will need to be deleted then added back in.**

Opening Analysis ToolPak:
**Once the Analysis ToolPak has been installed**, click the **Data** tab, then click the **Data Analysis** button in the **Analysis** group to the far right. A window with a list of analysis tools will appear.

Performing a Regression Analysis:
Once the Analysis ToolPak has been opened, scroll through the list of options to find **Regression** then click **OK**. Use the **Collapse arrow** to the right of the $x$ & $y$ input range textboxes to highlight the columns representing these data ranges. Including the **Title** of the column allows Excel to know what both variables are and produce plots accordingly, as long as the **Labels** checkbox has been checked. **Do not force your regression through the origin by clicking the Constant is Zero**
box, as most times it will provide an inaccurate understanding of either the data set or the fundamental relationship between the variables. Check the Confidence Level checkbox and change the level to 68%. In addition, click the Residuals and Residual Plot checkboxes. In order to create a new sheet for the resulting regression, ensure the New Worksheet Ply option is selected, and type a name for the new sheet into the textbox. Once all these steps are completed, press OK to perform the regression.

Understanding Regression Outputs:
Though regression analysis will be studied further in upper year courses, here are some important things to help comprehend the results of the Excel Regression analysis.

Underneath the table labelled Regression Statistics:
Observations – These are the number of data values that were used in the calculations (number of trials in the experiment). It is good practice to ensure that this number matches the number of data points to be included in the regression and ensure that the Labels box has been checked before performing the regression.

R-Squared – This value provides a measure of how well the regression line fits. A value of 1 indicates that the data is perfectly linear and thus the line passed directly through all data points. In practice, this degree of perfection will never be the case. An R-Squared value greater than 0.9 indicates a good fit.

From the 3rd table with column headings including Coefficients, Standard Error, etc.:
Coefficients – This column provides the y-intercept and slope of the line of best fit. The Intercept row indicates the y-intercept, and the variable row indicates the slope. If Labels were included in the analysis, the slope will be in terms of the x variable’s name. These values can be used to write the equation of the line of best fit in the form of $y = mx + b$.

Standard Error – This error is the value most frequently used in Module 2. It directly corresponds to the value of the propagated error that is calculated in an error analysis. It is also comparable to the standard error that one can obtain by using a statistical analysis. Standard error corresponds to a 68% confidence interval, and twice the standard error corresponds to a 95% confidence interval. The Analysis ToolPak regression tool calculates a standard error on the intercept as well as the slope.

Lower 95% and Upper 95% – These values are the lower and upper values bounding the confidence intervals for the slope and y-intercept. There is a 95% probability that the slope and intercept lie within the upper and lower limits. For example, if the upper and lower limits on the slope are 0.820 and 0.808, then the slope should be reported as $E = 0.814 \pm (0.820-0.808) = 0.814 \pm 0.012$. Thus, $\pm 0.012$ is the uncertainty or error associated with the estimate of $E = 0.814$ with a 95% confidence level. For the purposes of the Excel Word Assignment, use the Standard Error.

Residuals:
The residual plot indicates the adequacy of the line of best fit. If the line is of adequate fit, the residuals should be randomly distributed above and below the zero line (a perfect fit requires that all residuals are zero). If there is a systematic pattern in the residuals, this correlation suggests that a higher-order fit is necessary.
Using Descriptive Statistics:

Once the Analysis ToolPak has been opened, scroll through the list of options to find **Descriptive Statistics** then click **OK**. Use the **Collapse Arrow** to the right of the input range textbox to highlight the range of the data. Including the **Title** of the column allows Excel to know what the range is for, and it will name the resulting statistics as the header. If including the column header, ensure that the **Labels** checkbox has been checked. Check the checkboxes for **Summary Statistics** and **Confidence Level for the Mean**, changing the confidence to 68%. In order to create a new sheet for the resulting statistics, ensure the **New Worksheet Ply** option is selected, and type a name for the new sheet into the textbox. Once all these steps are completed, press **OK** to perform the calculations.

**Examples**

**Example Graph:**

![Example Graph](image)

*Figure 22: An example graph depicting the trends between initial height (cm) and bounce height (cm) for both a Rubber and Ping Pong Ball. The plot follows all the formatting requirements and should be used to produce clean looking graphs. The caption (this) should thoroughly explain the plot and if the trendlines are a good fit for the data. Generally, a correlation coefficient (R^2) value of close to 1 is a great fit for the data. The two trendlines on this plot both have R^2 values of higher then .99, making them extremely good fit for the data set and suggesting a highly linear relationship between the independent variable and the response for both series.*

**Example Table:**

*Table 2: An example table corresponding with the data from Figure 22. This Table contains the raw data and standard error in the initial and bounce heights of both a rubber and ping pong ball. This table does have some vertical lines, which are generally poor practice for maximizing white space, but may be important for separating distinct data sets, such as two different types of ball. Though it is appropriate to have these two data sets in the same table due to them undergoing the same trials, it may be better to separate this information into two distinct tables, depending on spacing in a given report.*
<table>
<thead>
<tr>
<th>Trial #</th>
<th>$h_r$ [cm]</th>
<th>$h_r$ Error [cm]</th>
<th>$h_b$ [cm]</th>
<th>$h_b$ Error [cm]</th>
<th>$h_p$ [cm]</th>
<th>$h_p$ Error [cm]</th>
<th>$h_p$ [cm]</th>
<th>$h_p$ Error [cm]</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>20</td>
<td>0.5</td>
<td>16</td>
<td>2</td>
<td>20</td>
<td>0.5</td>
<td>13</td>
<td>2</td>
</tr>
<tr>
<td>2</td>
<td>30</td>
<td>0.5</td>
<td>25</td>
<td>2</td>
<td>30</td>
<td>0.5</td>
<td>21</td>
<td>2</td>
</tr>
<tr>
<td>3</td>
<td>40</td>
<td>0.5</td>
<td>33</td>
<td>2</td>
<td>40</td>
<td>0.5</td>
<td>27</td>
<td>2</td>
</tr>
<tr>
<td>4</td>
<td>50</td>
<td>0.5</td>
<td>42</td>
<td>2</td>
<td>50</td>
<td>0.5</td>
<td>32</td>
<td>2</td>
</tr>
<tr>
<td>5</td>
<td>60</td>
<td>0.5</td>
<td>49</td>
<td>2</td>
<td>60</td>
<td>0.5</td>
<td>42</td>
<td>2</td>
</tr>
<tr>
<td>6</td>
<td>70</td>
<td>0.5</td>
<td>57</td>
<td>2</td>
<td>70</td>
<td>0.5</td>
<td>47</td>
<td>2</td>
</tr>
<tr>
<td>7</td>
<td>80</td>
<td>0.5</td>
<td>66</td>
<td>2</td>
<td>80</td>
<td>0.5</td>
<td>51</td>
<td>2</td>
</tr>
<tr>
<td>8</td>
<td>90</td>
<td>0.5</td>
<td>72</td>
<td>2</td>
<td>90</td>
<td>0.5</td>
<td>60</td>
<td>2</td>
</tr>
<tr>
<td>9</td>
<td>100</td>
<td>0.5</td>
<td>81</td>
<td>2</td>
<td>100</td>
<td>0.5</td>
<td>67</td>
<td>2</td>
</tr>
<tr>
<td>10</td>
<td>110</td>
<td>0.5</td>
<td>90</td>
<td>2</td>
<td>110</td>
<td>0.5</td>
<td>75</td>
<td>2</td>
</tr>
<tr>
<td>11</td>
<td>120</td>
<td>0.5</td>
<td>98</td>
<td>2</td>
<td>120</td>
<td>0.5</td>
<td>80</td>
<td>2</td>
</tr>
<tr>
<td>12</td>
<td>130</td>
<td>0.5</td>
<td>105</td>
<td>2</td>
<td>130</td>
<td>0.5</td>
<td>86</td>
<td>2</td>
</tr>
</tbody>
</table>